Sent From: [log in to unmask]


> Date: Wed, 18 Nov 1998 08:29:12 -0500 > Reply-to: [log in to unmask] > From: Jean Pierre Belanger <[log in to unmask]> > To: SISO - Run-Time Infrastructure and Communications Forum <[log in to unmask]> Subject: Re: Anybody using Red Hat Linux version of the RTI ? > > Hi! > > I am having problems using the RTI on Red Hat Linux and would appreciate > some help from outside the RTI Help Desk. > > I would like to know if anybody is using the Red Hat Linux version of the RTI. Yesterday I installed RTI 1.3v4 on a RedHat 5.1 system. I only tried the helloworld federate and it worked after adding the RTI library path to /etc/ld.so.config (See explanation below.) > Did you have problems with it ? Yes, see below. > Did you have to change compiler/install patches/ change the setup ? Yes, I found some updates (patches?) on the installation CD. > One of my problems is that following my installation, the RTI examples only execute if I am > logged as root (working well on other platforms as non-root); that problem seems to be > related with the start of a xterm window by the script federate.sh. For some odd > reason, the fedex application exits right away. Starting it without the xterm window is fine. I ran into the same problem. I traced it back to the LD_LIBRARY_PATH environment variable that is NOT passed by executables with the setuid/setgid bit set. XTerm has this bit set and the fedex can not find the RTI shared libraries. So I decided to put the RTI library path in /etc/ld.so.config. > > Thanks, > Jean-Pierre > > -- > Jean-Pierre Belanger, New Product Group Leader > OriginalSim - Framework for building distributed simulations. > Tel: 514-766-8868 Ex:28, Fax: 514-766-8861 > mailto:[log in to unmask], http://www.originalsim.com > Regards, Hartmut



To unsubscribe from the Z-ARCHIVE-SIW-CFI list, click the following link:
https://discussions.sisostds.org/index.htm?SUBED1=Z-ARCHIVE-SIW-CFI